aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 15:56:50 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 15:56:50 +0100
commit5a66a9ad3ff3c11da88fca48101116f7ab1c6eff (patch)
tree6ac772b8b7002f2605bc23282d02f7c84da671f1 /CMakeLists.txt
parentCookieInterceptor, making all cookies session cookies (diff)
downloadsmolbote-5a66a9ad3ff3c11da88fca48101116f7ab1c6eff.tar.xz
Minor fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7c7296..12afb57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ add_subdirectory(lib/downloads)
add_subdirectory(lib/navigation)
# configure a header file to pass version information
+# if you don't have git, or are building this off the source tarball, define versions in version.h.in
execute_process(COMMAND "git" "describe" WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE GitDescribe OUTPUT_STRIP_TRAILING_WHITESPACE)
execute_process(COMMAND "git" "describe" "--abbrev=0" WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE GitVersion OUTPUT_STRIP_TRAILING_WHITESPACE)
configure_file(src/version.h.in "${PROJECT_BINARY_DIR}/version.h")