aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-16 15:41:45 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-16 15:41:45 +0100
commitc3b20dc648cfd02d3a26bbd6fab0db5a7d39fc05 (patch)
tree573ad55f55da490d02d500875de8c53848702f59 /CMakeLists.txt
parentConverted repository to mercurial (diff)
downloadsmolbote-c3b20dc648cfd02d3a26bbd6fab0db5a7d39fc05.tar.xz
Fixed build scripts for use with the mercurial repository
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0586b90..589ccfb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,8 +52,8 @@ add_subdirectory(plugins/ProfileEditor)
# configure a header file to pass version information
# if you don't have git, or are building this off the source tarball, define versions in version.h.in
-execute_process(COMMAND "git" "describe" WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE GitDescribe OUTPUT_STRIP_TRAILING_WHITESPACE)
-execute_process(COMMAND "git" "describe" "--abbrev=0" WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE GitVersion OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process(COMMAND hg log -r '.' --template={latesttag} WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsVersion OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process(COMMAND hg identify --id WORKING_DIRECTORY ${PROJECT_SOURCE_DIR} OUTPUT_VARIABLE VcsCommit OUTPUT_STRIP_TRAILING_WHITESPACE)
configure_file(src/version.h.in "${PROJECT_BINARY_DIR}/version.h")
set(SourceCode
@@ -116,4 +116,4 @@ target_link_libraries(poi Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineW
target_link_libraries(poi configuration)
target_link_libraries(poi bookmarks downloads navigation)
-install(TARGETS poi DESTINATION bin CONFIGURATIONS Release)
+install(TARGETS poi RUNTIME DESTINATION bin CONFIGURATIONS Release)