aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-07-17 15:35:43 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-07-17 15:35:43 +0200
commitf143900bd3db40a5e908f8e0e40557346f908592 (patch)
tree1c41776f670e1e8db1d22726f07b418e4808fded /CMakeLists.txt
parentAdd vendor.cmake (diff)
downloadsmolbote-f143900bd3db40a5e908f8e0e40557346f908592.tar.xz
Switch vcs to git
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 7 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42f7c74..ed80038 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.10.0)
-project(smolbote)
+project(smolbote CXX)
include(FeatureSummary)
@@ -7,8 +7,6 @@ set(VENDOR "${CMAKE_SOURCE_DIR}/vendor.cmake" CACHE FILEPATH "vendor configurati
include(${VENDOR})
# Options
-option(MercurialRepo "Get version information from .hg" ON)
-option(CompilerWarnings "Compiler warnings" ON)
option(QtDeprecatedWarnings "Qt deprecated warnings" ON)
option(UseLibCpp "Use libc++ over stdlibc++ (requires clang)" OFF)
option(Tests "Enable/disable some basic autotests" OFF)
@@ -28,15 +26,6 @@ endif(Plasma)
# Global C++ settings
set(CMAKE_CXX_STANDARD 17)
-if(CompilerWarnings)
- if(CMAKE_COMPILER_IS_GNUCC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra")
- endif()
- if(MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /W4")
- endif()
-endif(CompilerWarnings)
-
if(QtDeprecatedWarnings)
add_definitions(-DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050900)
endif(QtDeprecatedWarnings)
@@ -47,8 +36,6 @@ if (UseLibCpp)
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")
endif (UseLibCpp)
-
-
# configure a header file to pass version information
# if repo is missing or option is turned off, version.h.in can be configured
# with static values
@@ -76,9 +63,10 @@ if (Tests)
endif()
# Summarize
-message("=== Configuration summary ===")
+message(STATUS "=== Configuration summary ===")
feature_summary(WHAT ALL)
-message("Building ${poi_NAME}")
-message("Version='${VerInfo}' bookmark='${VerBookmark}' commit='${VerCommit}'")
-message("vendor.cmake: ${VENDOR}")
-message("C++ flags: ${CMAKE_CXX_FLAGS}")
+message(STATUS "Building ${poi_NAME} ${VerInfo}; version ${VerDescribe} ${VerBranch}:${VerCommit}")
+message(STATUS "vendor.cmake: ${VENDOR}")
+message(STATUS "CXX compiler: ${CMAKE_CXX_COMPILER_ID}")
+message(STATUS "C++ flags: ${CMAKE_CXX_FLAGS}")
+