aboutsummaryrefslogtreecommitdiff
path: root/lib/bookmarks/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-07 00:48:27 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-07 00:48:27 +0100
commite0f64f9330fc30553dc9d8dcf308079f5d391526 (patch)
tree8c21a08f25208150ed4f0bcbf8496334c2e08bcc /lib/bookmarks/CMakeLists.txt
parentUpdated ReadMe and pkgbuild (diff)
downloadsmolbote-e0f64f9330fc30553dc9d8dcf308079f5d391526.tar.xz
Added BookmarksModel
TODO: Editing bookmarks TODO: Saving bookmarks BUG: Completer doesn't search through folders
Diffstat (limited to 'lib/bookmarks/CMakeLists.txt')
-rw-r--r--lib/bookmarks/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/bookmarks/CMakeLists.txt b/lib/bookmarks/CMakeLists.txt
index 8fb7f45..53ba51e 100644
--- a/lib/bookmarks/CMakeLists.txt
+++ b/lib/bookmarks/CMakeLists.txt
@@ -4,6 +4,12 @@ add_library(bookmarks
bookmarksform.ui
bookmarkswidget.cpp
bookmarkswidget.h
+ # model
+ bookmarkitem.cpp
+ bookmarkitem.h
+ bookmarksmodel.cpp
+ bookmarksmodel.h
+ # xbel
xbel.cpp
xbel.h)