aboutsummaryrefslogtreecommitdiff
path: root/lib/configuration/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-23 10:25:28 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-23 10:25:28 +0200
commit84137d9c3bf21e0a32f8a50a9bf9a93584754b75 (patch)
treecb539940bc33375dd477db545bb1fac9ab17ade6 /lib/configuration/CMakeLists.txt
parentclang-format pass (diff)
downloadsmolbote-84137d9c3bf21e0a32f8a50a9bf9a93584754b75.tar.xz
Add Configuration::setValue and Configuration::setShortcut
Change MainWindow to use setShortcut
Diffstat (limited to 'lib/configuration/CMakeLists.txt')
-rw-r--r--lib/configuration/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/lib/configuration/CMakeLists.txt b/lib/configuration/CMakeLists.txt
index 0db2b67..ed0235d 100644
--- a/lib/configuration/CMakeLists.txt
+++ b/lib/configuration/CMakeLists.txt
@@ -1,3 +1,11 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+#set(CMAKE_AUTOUIC ON)
+#set(CMAKE_AUTORCC ON)
+
add_library(configuration
configuration.cpp
configuration.h)
@@ -6,6 +14,6 @@ target_include_directories(configuration
PRIVATE ${Boost_INCLUDE_DIRS})
target_link_libraries(configuration
- Qt5::Core
+ Qt5::Core Qt5::Widgets
${Boost_LIBRARIES}
)