aboutsummaryrefslogtreecommitdiff
path: root/lib/configuration/CMakeLists.txt
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2024-04-28 17:46:14 +0300
committeraqua <aqua@iserlohn-fortress.net>2024-04-28 17:46:14 +0300
commitfd87ed4d17dd8fc6fb7fbc936861393c6455815d (patch)
tree0d95ec29b6e6d5948c07ee59c5c9a94653d5ea6b /lib/configuration/CMakeLists.txt
parentAdded poi resources to sources (diff)
downloadsmolbote-fd87ed4d17dd8fc6fb7fbc936861393c6455815d.tar.xz
Added libConfiguration unit test
Diffstat (limited to 'lib/configuration/CMakeLists.txt')
-rw-r--r--lib/configuration/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/configuration/CMakeLists.txt b/lib/configuration/CMakeLists.txt
index 9e2f34e..7952eba 100644
--- a/lib/configuration/CMakeLists.txt
+++ b/lib/configuration/CMakeLists.txt
@@ -4,3 +4,9 @@ add_library(configuration STATIC
)
target_link_libraries(configuration PUBLIC Qt6::Gui)
target_include_directories(configuration PUBLIC ${CMAKE_CURRENT_LIST_DIR})
+
+add_executable(test_configuration test/configuration.cpp)
+target_link_libraries(test_configuration PUBLIC configuration GTest::gtest_main)
+gtest_add_tests(TARGET test_configuration
+ SOURCES test/configuration.cpp
+ WORKING_DIRECTORY ${CMAKE_CURRENT_LIST_DIR}/test)