aboutsummaryrefslogtreecommitdiff
path: root/lib/configuration/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-03-22 14:59:04 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-03-22 14:59:04 +0200
commit74870600fa54a48d4c1ce4b19861a9b0ce027fee (patch)
treed79eb50c18f1f62e937a1d1fe2e7180c7c14d06a /lib/configuration/meson.build
parentRemove ProfileInterface (diff)
downloadsmolbote-74870600fa54a48d4c1ce4b19861a9b0ce027fee.tar.xz
lib/configuration improvements
Configuration changes: - Configuration::value return type is now [[nodiscard]] - Configuration::value<T> is now a generic template that only works with the exact types of the underlying std::variant - Add Configuration::value<concept_value_t> for standard library types compatible with the types of std::variant - Add Configuration::shortcut<> placeholder, and QAction and QKeySequence specializations as a convenient way to set up shortcuts - Deprecate setShortcut - Add Configuration::read_file convenience member that takes file path as parameter Format changes: - Configuration files can now have sections, specified as [section name]. Section names are prepended to keys. Section names cannot be nested. - Configuration files can now have @@include directives, causing another file to be read as well. The included file is not treated as nested into a section, and will overwrite values previously set. Others: - add some tests for libconfiguration. QAction/QKeySequence require a QApplication be set up, so the test application may require running xorg/wayland. old coverage: lines: 15.6% (960 out of 6172) branches: 9.9% (1187 out of 12012) new coverage: lines: 17.1% (1067 out of 6254) branches: 11.0% (1388 out of 12644)
Diffstat (limited to 'lib/configuration/meson.build')
-rw-r--r--lib/configuration/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/lib/configuration/meson.build b/lib/configuration/meson.build
index 939a493..a0d915c 100644
--- a/lib/configuration/meson.build
+++ b/lib/configuration/meson.build
@@ -1,5 +1,14 @@
dep_configuration = declare_dependency(
include_directories: include_directories('.'),
- link_with: static_library('configuration', ['configuration.cpp'], dependencies: dep_qt5)
+ link_with: static_library('configuration', ['configuration.cpp', 'qt_specialization.cpp'], dependencies: dep_qt5)
+)
+
+test('configuration: parser',
+ executable('configuration-parser',
+ sources: [ 'test/parser.cpp' ],
+ dependencies: [ dep_qt5, dep_gtest, dep_configuration ]
+ ),
+ env: environment({ 'CONFIGFILE' : meson.current_source_dir()/'test/defaultrc.ini' }),
+ workdir: meson.current_source_dir()/'test'
)