aboutsummaryrefslogtreecommitdiff
path: root/lib/urlfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-21 13:48:23 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-21 13:48:23 +0200
commit19137b3233c31da75973a3217558ea6bd6570bad (patch)
treee1e2aa014354b7a50c5db2895c3b3fffd9d718d5 /lib/urlfilter/CMakeLists.txt
parentFix install paths for icon, desktop and profile (diff)
downloadsmolbote-19137b3233c31da75973a3217558ea6bd6570bad.tar.xz
urlfilter: base AdBlockRule off FilterLeaf
Diffstat (limited to 'lib/urlfilter/CMakeLists.txt')
-rw-r--r--lib/urlfilter/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/lib/urlfilter/CMakeLists.txt b/lib/urlfilter/CMakeLists.txt
index 9940222..20466d3 100644
--- a/lib/urlfilter/CMakeLists.txt
+++ b/lib/urlfilter/CMakeLists.txt
@@ -5,15 +5,6 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
add_library(urlfilter
- filterrule.cpp
- filterrule.h
-
- formats/adblockrule.cpp
- formats/adblockrule.h
-
- formats/hostlistrule.cpp
- formats/hostlistrule.h
-
# filter tree
filtertree.cpp
filtertree.h
@@ -21,6 +12,11 @@ add_library(urlfilter
filterleaf.h
domain.cpp
domain.h
+
+ formats/adblockrule.cpp
+ formats/adblockrule.h
+ formats/hostlistrule.cpp
+ formats/hostlistrule.h
)
target_link_libraries(urlfilter Qt5::WebEngineWidgets)