aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2024-05-01 11:17:07 +0300
committeraqua <aqua@iserlohn-fortress.net>2024-05-01 11:17:07 +0300
commit7feefe9d5c922481081d31b12e02f42d9e028ef9 (patch)
tree6aee14710adeef4bcc0a86dd800df927f86342fd /linux/makepkg/PKGBUILD
parentAdded libConfiguration unit test (diff)
downloadsmolbote-master.tar.xz
Drop python-kcofiglib build time dependencyHEADmaster
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 749da87..efdea15 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -16,7 +16,7 @@ arch=('x86_64' 'aarch64')
license=('GPL3')
depends=('qt6-svg' 'qt6-webengine' 'spdlog' 'fmt')
-makedepends=('git' 'cmake' 'python-kconfiglib' 'openssl' 'qt6-tools' 'scdoc')
+makedepends=('git' 'cmake' 'openssl' 'qt6-tools' 'scdoc')
optdepends=('firejail: launch a sandboxed instance')
# use git+file:///path/to/your/repo to build from a local repo
@@ -29,12 +29,11 @@ b2sums=('SKIP'
validpgpkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
prepare() {
+ msg2 "Populate third_party packages..."
mkdir "$srcdir/smolbote/third_party"
ln -s "$srcdir/SingleApplication-3.4.1" "$srcdir/smolbote/third_party/SingleApplication"
- cd $srcdir/smolbote
- KCONFIG_CONFIG=linux/.config alldefconfig
-
+ msg2 "Configure..."
cmake -S $srcdir/smolbote -B $srcdir/build \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \