aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2024-04-26 23:04:14 +0300
committeraqua <aqua@iserlohn-fortress.net>2024-04-26 23:16:30 +0300
commit1cf1164932a83a1485db3ba02328a7f6890042db (patch)
tree5f2616465d29fcc39fec0c1591dadc67b91300db /linux/makepkg/PKGBUILD
parentAdded cmakelists (diff)
downloadsmolbote-1cf1164932a83a1485db3ba02328a7f6890042db.tar.xz
Updated pkgbuild
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD56
1 files changed, 12 insertions, 44 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 39aa84b..9f3fae9 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -18,7 +18,7 @@ arch=('x86_64' 'aarch64')
license=('GPL3')
depends=('qt6-svg' 'qt6-webengine' 'spdlog' 'fmt')
-makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt6-tools' 'scdoc')
+makedepends=('git' 'cmake' 'python-kconfiglib' 'openssl' 'qt6-tools' 'scdoc')
optdepends=('firejail: launch a sandboxed instance')
# this isn't a hard requirement, simply a workaround as the build script
@@ -28,27 +28,22 @@ options=(!buildflags)
# use git+file:///path/to/your/repo to build from a local repo
source=("git+https://neueland.iserlohn-fortress.net/cgit/smolbote"
- "https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.5.1.tar.gz"
- "https://neueland.iserlohn-fortress.net/releases/args.hxx-6.2.2.tar.xz"{,.sig})
+ "https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.4.1.tar.gz")
-b2sums=('SKIP'
- '924cef0b6aeb76aace3444f46141acb58c5f5019e1e09c78e1b1d973f1689283b5f5f7612dc58dc542fc04364197128f2f3f9e1a97b8b78e704fae5d995a8eca'
- '440e357006883fbf1b1a796051500a6b068858a35947cd1119767bed8e0a86a7db4aff16498934d7217c375fe643da03c22007e438f30899e247153f25c922b6'
- 'SKIP')
+sha256sums=('SKIP'
+ '7dfa5cafc30ae6d8b108fff7e99d35e52e728e9c2876202bcd612dbb75cc44ea')
validgpgkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
prepare() {
- mkdir "$srcdir/smolbote/subprojects/packagecache/"
- ln -s "$srcdir/SingleApplication-3.5.1" "$srcdir/smolbote/subprojects/"
- ln -s "$srcdir/args.hxx-6.2.2" "$srcdir/smolbote/subprojects/"
-
- msg2 "Patching SingleApplication"
- cp "$srcdir/smolbote/subprojects/packagefiles/SingleApplication/meson.build" "$srcdir/SingleApplication-3.5.1/"
- cp "$srcdir/smolbote/subprojects/packagefiles/SingleApplication/meson_options.txt" "$srcdir/SingleApplication-3.5.1/"
+ mkdir "$srcdir/smolbote/third_party"
+ ln -s "$srcdir/SingleApplication-3.4.1" "$srcdir/smolbote/third_party/SingleApplication"
cd $srcdir/smolbote
KCONFIG_CONFIG=linux/.config alldefconfig
+
+ cmake -S $srcdir/smolbote -B $srcdir/build \
+ -DCMAKE_INSTALL_PREFIX=/usr
}
pkgver() {
@@ -58,25 +53,8 @@ pkgver() {
}
build() {
- mkdir -p $srcdir/build
-
- # For a list of configureable options, check smolbote/meson_options.txt, or run `meson configure` in $srcdir/build
-
- # --wrap-mode=nodownload - disable meson from downloading dependency wraps. This will cause it to fail if makedepends are not found by pkg-config or cmake.
- # --wrap-mode=nofallback - disable downloads as a fallback too. Implies --wrap-mode=nodownload
- # --buildtype=plain - meson won't add any flags to the command line
- # --prefix=... - install prefix
- # --auto-features=disabled - features should be explicitly enabled
- # b_pie: Build executables as position independent
- # b_lto: Use link time optimization
- meson setup \
- --buildtype=plain --prefix=$_prefix --wrap-mode=nodownload --auto-features=disabled \
- -Db_pie=true -Ddefault_library=static \
- -Dmanpage=true \
- $srcdir/smolbote $srcdir/build
-
- # Build
- ninja -C $srcdir/build "$MAKEFLAGS"
+ echo "make flags: ${MAKEFLAGS}"
+ cmake --build $srcdir/build -j16
}
#check() {
@@ -84,16 +62,6 @@ build() {
#}
package() {
- # Install
- cd $srcdir/build
- DESTDIR="$pkgdir" ninja install
-
- if [ $_signPlugins == "1" ]; then
- msg "Signing plugins"
- for so in $pkgdir/$_prefix/lib/smolbote/plugins/*.so; do
- openssl dgst -sha256 -sign $srcdir/build/lib/pluginloader/privateKey.pem -out $so.sig $so
- msg2 "Signed $(basename $so)"
- done
- fi
+ DESTDIR="$pkgdir" cmake --install $srcdir/build --strip
}