aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authoraqua <aqua@iserlohn-fortress.net>2024-04-23 11:22:02 +0300
committeraqua <aqua@iserlohn-fortress.net>2024-04-23 11:38:55 +0300
commit3f72c39fb0e95d45d15bde64661040e920574a85 (patch)
tree49bde891396d92ecd61c3d833e071c897f1eabe2 /linux/makepkg/PKGBUILD
parentFix compile error with meson unstable-kconfig module (diff)
downloadsmolbote-3f72c39fb0e95d45d15bde64661040e920574a85.tar.xz
Ported to qt6
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD58
1 files changed, 30 insertions, 28 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 5bcf684..34d54ef 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -3,14 +3,16 @@
## not-use flags
# Enable plugin signing:
_signPlugins=0
-# Enable breakpad integraton:
-_enableBreakpad=0
+# test
+_test=0
+_branch=devel
+_optimized=0
# install prefix
-_prefix='/usr/local'
+_prefix='/usr'
pkgname=smolbote-git
pkgdesc='Yet another no-frills browser'
-pkgver=0
+pkgver=r638.be627c1
pkgrel=1
url="https://neueland.iserlohn-fortress.net/gitea/smolbote"
@@ -19,33 +21,46 @@ install="smolbote.install"
arch=('x86_64' 'aarch64')
license=('GPL3')
-depends=('qt5-svg' 'qt5-webengine>=5.11.0' 'spdlog')
-makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc' 'catch2')
-if [ $_enableBreakpad == "1" ]; then
- makedepends+=('breakpad-git')
-fi
+depends=('qt6-svg' 'qt6-webengine' 'spdlog' 'fmt')
+makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt6-tools' 'scdoc')
optdepends=('firejail: launch a sandboxed instance')
+# this isn't a hard requirement, simply a workaround as the build script
+# sets some additional hardening flags that the default makepkg.conf
+# will turn down
+options=(!buildflags)
+
# use git+file:///path/to/your/repo to build from a local repo
source=("git+https://neueland.iserlohn-fortress.net/cgit/smolbote"
- "https://neueland.iserlohn-fortress.net/releases/SingleApplication-3.1.1a.tar.xz"{,.sig}
+ "https://github.com/itay-grudev/SingleApplication/archive/refs/tags/v3.5.1.tar.gz"
"https://neueland.iserlohn-fortress.net/releases/args.hxx-6.2.2.tar.xz"{,.sig})
+if [ $_optimized == "1" ]; then
+ source+=(meson.build.diff)
+fi
b2sums=('SKIP'
- 'cec3de8dbf252bfa6dc488e5a1440695f4dd3abffdf30948b7d1a3df3d9c85911e981c802ed5a882f1407315114529f4016e55c7d05fbbd1dafe5495b0a63f4a'
- 'SKIP'
+ '924cef0b6aeb76aace3444f46141acb58c5f5019e1e09c78e1b1d973f1689283b5f5f7612dc58dc542fc04364197128f2f3f9e1a97b8b78e704fae5d995a8eca'
'440e357006883fbf1b1a796051500a6b068858a35947cd1119767bed8e0a86a7db4aff16498934d7217c375fe643da03c22007e438f30899e247153f25c922b6'
'SKIP')
-validgpgkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
+validpgpkeys=('BB1C090188E3E32B375C13FD095DE26BC16D2E98')
prepare() {
mkdir "$srcdir/smolbote/subprojects/packagecache/"
- ln -s "$srcdir/SingleApplication-3.1.1a" "$srcdir/smolbote/subprojects/"
+ ln -s "$srcdir/SingleApplication-3.5.1" "$srcdir/smolbote/subprojects/"
ln -s "$srcdir/args.hxx-6.2.2" "$srcdir/smolbote/subprojects/"
cd $srcdir/smolbote
+
+ if [ $_test == "1" ]; then
+ git checkout ${_branch}
+ fi
+
KCONFIG_CONFIG=linux/.config alldefconfig
+
+if [ $_optimized == "1" ]; then
+ patch -p1 -i ${srcdir}/meson.build.diff
+fi
}
pkgver() {
@@ -72,14 +87,8 @@ build() {
-Dmanpage=true \
$srcdir/smolbote $srcdir/build
- if [ $_enableBreakpad == "1" ]; then
- msg2 "Enabling crashhandler"
- meson configure -Ddebug=true -Dcrashhandler=enabled
- KCONFIG_CONFIG=linux/.config setconfig USEBREAKPAD=y
- fi
-
# Build
- ninja -C $srcdir/build
+ ninja -C $srcdir/build "$MAKEFLAGS"
}
#check() {
@@ -98,12 +107,5 @@ package() {
msg2 "Signed $(basename $so)"
done
fi
-
- if [ $_enableBreakpad == "1" ]; then
- msg "Installing debug symbols"
- ninja -C $srcdir/build linux/poi.sym
- install -dm644 $pkgdir/$_prefix/lib/smolbote/symbols/poi/$(head -n1 linux/poi.sym | awk '{ print $(NF-1) }')
- install -m644 -t $pkgdir/$_prefix/lib/smolbote/symbols/poi/$(head -n1 linux/poi.sym | awk '{ print $(NF-1) }') $srcdir/build/linux/poi.sym
- fi
}