aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-12 18:19:40 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-12 21:23:30 +0200
commit43a5be4dfa77061ffb4488f81aa965940c1d6c2d (patch)
tree0a4186ee2949af781563deb95e1ca182d86ce160 /linux/makepkg/PKGBUILD
parentUnlink plugins from lib/ libraries (diff)
downloadsmolbote-43a5be4dfa77061ffb4488f81aa965940c1d6c2d.tar.xz
Update readme
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 22c56b3..cac761b 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=1
_tag=""
_describe=""
_commit=""
-_branch=""
+_branch="master"
url="https://neueland.iserlohn-fortress.net/smolbote"
install="smolbote.install"
@@ -21,7 +21,7 @@ optdepends=('firejail: launch a sandboxed instance')
makedepends=('git' 'cmake' 'pkg-config' 'asciidoctor')
# this is the central repository
-source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
+source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git#branch=master"
"git+https://github.com/itay-grudev/SingleApplication.git")
sha512sums=('SKIP'
@@ -40,7 +40,10 @@ prepare() {
_tag="r$(git rev-list --count HEAD)"
_describe="r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD)"
_commit=$(git rev-parse HEAD)
- _branch=$(git rev-parse --abbrev-ref HEAD)
+ # makepkg branches off the cloned repository into makepkg
+ #_branch=$(git rev-parse --abbrev-ref HEAD)
+
+ msg2 "[$(pwd)]: build $_branch:$_commit"
}
pkgver() {