aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-09-28 14:12:46 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-09-28 14:12:46 +0200
commit4ea2417101ff930495e07c0afdb34cbae533fee7 (patch)
tree6440db9713a75723b6c17bf22198e6996b1cfdba /linux/makepkg/PKGBUILD
parentbreakpad: keep all build artifacts (diff)
downloadsmolbote-4ea2417101ff930495e07c0afdb34cbae533fee7.tar.xz
breakpad: Use system breakpad by default
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index e6973dd..2a5c957 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -47,6 +47,10 @@ build() {
# -DUseLibCpp Off
# -DTests Off
# -DPlasma Off
+ # -DBreakpad Off If you turn it on, add a breakpad
+ # dependancy to makedepends, or modify
+ # 3rd-pary/breakpad/CMakeLists.txt
+ # accordingly.
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=$pkgdir/usr/local \
@@ -54,6 +58,7 @@ build() {
-DVerDescribe=$_describe \
-DVerCommit=$_commit \
-DVerBranch=$_branch \
+ -DBreakpad=On \
$srcdir/smolbote
# Build