aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-14 11:33:32 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-14 11:33:42 +0200
commit77d7e6a764011a3b6dc13afbf7b26be39cb56dbd (patch)
treea9e0a8d28a3a81a44d94be920494e2e7f0427770 /linux/makepkg/PKGBUILD
parentunstable: KWallet integration (diff)
downloadsmolbote-77d7e6a764011a3b6dc13afbf7b26be39cb56dbd.tar.xz
Update CMakeLists option names
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index cac761b..240f711 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -53,25 +53,17 @@ pkgver() {
build() {
# generate makefile
-
- # option default
- # -DQtDeprecatedWarnings On
- # -DUseLibCpp Off
- # -DTests Off
- # -DPlasma Off
- # -DBreakpad Off If you turn it on, add a breakpad
- # dependancy to makedepends, or modify
- # 3rd-pary/breakpad/CMakeLists.txt
- # accordingly.
-
+ # see doc/Building.asciidoc for list of options
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=$pkgdir/usr/local \
- -DVerTag=$_tag \
- -DVerDescribe=$_describe \
- -DVerCommit=$_commit \
- -DVerBranch=$_branch \
+ -Dpoi_Version="$_tag" \
+ -Dpoi_Describe="$pkgver" \
+ -Dpoi_Build="$_branch:$_commit" \
$srcdir/smolbote
+ # if you want to manually customize the build, you can use ccmake here
+ ccmake .
+
# Build
make
}