aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-04 17:10:11 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-04 17:12:42 +0200
commit8de34328c5d970454190953a4aab7b8b03dc0b1c (patch)
tree1d534279d1fba0d1e1202919959a01d12381930b /linux/makepkg/PKGBUILD
parentUpdate pkgbuild (diff)
downloadsmolbote-8de34328c5d970454190953a4aab7b8b03dc0b1c.tar.xz
Update pkgbuild to use asciidoctor
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 4d0c830..e5465d4 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -17,7 +17,7 @@ license=('GPL3')
depends=('qt5-webengine>=5.11.0' 'boost-libs>=1.66.0')
optdepends=('firejail: launch a sandboxed instance')
-makedepends=('git' 'cmake' 'pkg-config' 'asciidoc')
+makedepends=('git' 'cmake' 'pkg-config' 'asciidoctor')
# this is the central repository
source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
@@ -84,7 +84,7 @@ package() {
install -Dm644 $srcdir/smolbote/data/poi.profile $pkgdir/usr/local/lib/smolbote/poi.profile
msg2 "Installing manpage"
- a2x --format=manpage $srcdir/smolbote/doc/smolbote.7.asciidoc
+ asciidoctor --backend=manpage $srcdir/smolbote/doc/smolbote.7.asciidoc
gzip $srcdir/smolbote/doc/smolbote.7
install -Dm644 $srcdir/smolbote/doc/smolbote.7.gz $pkgdir/usr/local/man/man7/smolbote.7.gz
}