aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-07-29 14:08:27 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-07-29 14:08:27 +0200
commit9c47ceeef79caa02c5ee810659d8f784676b3f71 (patch)
tree97282bbdc20b844cd7ca63cdb82af67ba1dc5098 /linux/makepkg/PKGBUILD
parentUrlRequestInterceptor: add filter rules (diff)
downloadsmolbote-9c47ceeef79caa02c5ee810659d8f784676b3f71.tar.xz
Update build instructions
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index ba8f893..e6973dd 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -28,15 +28,15 @@ validgpgkeys=(# Aqua-sama <aqua@iserlohn-fortress.net>
prepare() {
cd smolbote
- _tag=$(git describe --tags --abbrev=0)
- _describe=$(git describe --tags)
+ _tag="r$(git rev-list --count HEAD)"
+ _describe="r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD)"
_commit=$(git rev-parse HEAD)
_branch=$(git rev-parse --abbrev-ref HEAD)
}
pkgver() {
cd smolbote
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ echo $_describe | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {