aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-03 16:48:26 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-03 16:48:26 +0200
commitae2a713f26fd58f397aaf93242f24c85dee98a2b (patch)
treedb69c96f6419e011cfc1c6e6081613d7a0f0d7cc /linux/makepkg/PKGBUILD
parentSubwindow: only keep tab history for restore tab action (diff)
downloadsmolbote-ae2a713f26fd58f397aaf93242f24c85dee98a2b.tar.xz
Convert documentation into asciidoc from markdown
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 2e0e755..4bb7571 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -17,7 +17,7 @@ license=('GPL3')
depends=('qt5-webengine>=5.11.0' 'boost-libs>=1.66.0')
optdepends=('firejail: launch a sandboxed instance')
-makedepends=('git' 'cmake' 'pkg-config' 'go-md2man')
+makedepends=('git' 'cmake' 'pkg-config' 'asciidoc')
# this is the central repository
source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
@@ -66,7 +66,6 @@ build() {
-DVerDescribe=$_describe \
-DVerCommit=$_commit \
-DVerBranch=$_branch \
- -DBreakpad=On \
$srcdir/smolbote
# Build
@@ -77,16 +76,16 @@ package() {
# Install
make install
- # icon and .desktop
- install -Dm644 "${srcdir}/smolbote/data/poi.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/poi.svg"
- install -Dm644 "${srcdir}/smolbote/linux/poi.desktop" "${pkgdir}/usr/share/applications/poi.desktop"
+ msg2 "Installing icon and .desktop"
+ install -Dm644 $srcdir/smolbote/data/poi.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/poi.svg
+ install -Dm644 $srcdir/smolbote/linux/poi.desktop $pkgdir/usr/share/applications/poi.desktop
- # firejail profile
- install -Dm644 "${srcdir}/smolbote/data/poi.profile" "${pkgdir}/usr/local/lib/smolbote/poi.profile"
+ msg2 "Installing firejail profile"
+ install -Dm644 $srcdir/smolbote/data/poi.profile $pkgdir/usr/local/lib/smolbote/poi.profile
- msg2 "Install manpage"
- go-md2man -in $srcdir/smolbote/linux/man/smolbote.md -out smolbote.7
- gzip smolbote.7
- install -Dm644 smolbote.7.gz $pkgdir/usr/local/man/man7/smolbote.7.gz
+ msg2 "Installing manpage"
+ a2x --format=manpage $srcdir/doc/smolbote.7.asciidoc
+ gzip $srcdir/doc/smolbote.7
+ install -Dm644 $srcdir/doc/smolbote.7.gz $pkgdir/usr/local/man/man7/smolbote.7.gz
}