aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-20 15:44:05 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-20 15:44:05 +0200
commitccbc06f6041a2688019b5d8a15e7187a4911ee89 (patch)
tree43bd2f71ed8255b97c3af92b69ba25b084bff690 /linux/makepkg/PKGBUILD
parentAdd Kconfiglib to parse Kconfig/.config (diff)
downloadsmolbote-ccbc06f6041a2688019b5d8a15e7187a4911ee89.tar.xz
Add cmake manpage target
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index c327b47..005f46a 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -66,22 +66,11 @@ build() {
# Build
make
+ make manpage
}
package() {
# Install
DESTDIR="$pkgdir" make install
-
- msg2 "Installing icon and .desktop"
- install -Dm644 $srcdir/smolbote/data/poi.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/poi.svg
- install -Dm644 $srcdir/smolbote/linux/poi.desktop $pkgdir/usr/share/applications/poi.desktop
-
- msg2 "Installing firejail profile"
- install -Dm644 $srcdir/smolbote/data/poi.profile $pkgdir/usr/local/lib/smolbote/poi.profile
-
- msg2 "Installing manpage"
- asciidoctor --backend=manpage $srcdir/smolbote/doc/smolbote.7.asciidoc
- gzip $srcdir/smolbote/doc/smolbote.7
- install -Dm644 $srcdir/smolbote/doc/smolbote.7.gz $pkgdir/usr/local/man/man7/smolbote.7.gz
}