aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-11-20 12:59:53 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-11-20 12:59:53 +0100
commitdb58900d3d289e2b25112963375edf183dca032f (patch)
tree629b49ebeb26b988706560b0cb965ec5ff04fadc /linux/makepkg/PKGBUILD
parentAdd adblockrule_parse (diff)
downloadsmolbote-db58900d3d289e2b25112963375edf183dca032f.tar.xz
Make keyboard shortcut defaults configurable
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index bf62f9c..fc3d16d 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -14,15 +14,13 @@ license=('GPL3')
depends=('qt5-webengine>=5.11.0' 'boost-libs>=1.66.0')
optdepends=('firejail: launch a sandboxed instance')
-makedepends=('git' 'meson' 'pkg-config' 'asciidoctor')
+makedepends=('git' 'meson' 'pkg-config' 'python-kconfiglib' 'asciidoctor')
# this is the central repository
source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
- "git+https://github.com/itay-grudev/SingleApplication.git"
- "git+https://github.com/ulfalizer/Kconfiglib.git")
+ "git+https://github.com/itay-grudev/SingleApplication.git")
sha512sums=('SKIP'
- 'SKIP'
'SKIP')
#validgpgkeys=(# Aqua-sama <aqua@iserlohn-fortress.net>
@@ -34,8 +32,6 @@ prepare() {
git submodule init
git config submodule.3rd-party/SingleApplication/SingleApplication.git.url $srcdir/SingleApplication
git submodule update 3rd-party/SingleApplication/SingleApplication.git
- git config submodule.tools/Kconfiglib.url $srcdir/Kconfiglib
- git submodule update tools/Kconfiglib
}
pkgver() {
@@ -51,12 +47,19 @@ build() {
# For a list of configureable options, check smolbote/meson_options.txt, or
# run `meson configure` in $srcdir/build
- meson --buildtype=release --prefix=/usr/local --auto-features=disabled $srcdir/build
+ # --buildtype=plain - meson won't add any flags to the command line
+ # --prefix=... - install prefix
+ # --auto-features=disabled - features should be explicitly enabled
+ meson --buildtype=plain --prefix=/usr/local --auto-features=disabled $srcdir/build
- # Build
cd $srcdir/build
+
+ # Toggle features
+ #meson configure -DBreakpad=enabled
meson configure -DPlasma=enabled
meson configure -Dmanpage=enabled
+
+ # Build
ninja
}