aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-02 14:26:56 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-02 14:26:56 +0200
commitf1f3657d21ddfbbb00b397b799d386dd9e1ff14e (patch)
tree6cd29075b2529f2c7669bcf10c65d979c3078fd6 /linux/makepkg/PKGBUILD
parentAdd SingleApplication as a git submodule (diff)
downloadsmolbote-f1f3657d21ddfbbb00b397b799d386dd9e1ff14e.tar.xz
Update PKGBUILD
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 2a5c957..2e0e755 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=smolbote-git
pkgdesc='Yet another no-frills browser'
-pkgver=0
+pkgver=r0
pkgrel=1
_tag=""
_describe=""
@@ -20,14 +20,22 @@ optdepends=('firejail: launch a sandboxed instance')
makedepends=('git' 'cmake' 'pkg-config' 'go-md2man')
# this is the central repository
-source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git")
+source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
+ "git+https://github.com/itay-grudev/SingleApplication.git")
-sha512sums=('SKIP')
-validgpgkeys=(# Aqua-sama <aqua@iserlohn-fortress.net>
- BB1C090188E3E32B375C13FD095DE26BC16D2E98)
+sha512sums=('SKIP'
+ 'SKIP')
+
+#validgpgkeys=(# Aqua-sama <aqua@iserlohn-fortress.net>
+# BB1C090188E3E32B375C13FD095DE26BC16D2E98)
prepare() {
cd smolbote
+
+ git submodule init
+ git config submodule.3rd-party/SingleApplication/SingleApplication.git.url $srcdir/SingleApplication
+ git submodule update 3rd-party/SingleApplication/SingleApplication.git
+
_tag="r$(git rev-list --count HEAD)"
_describe="r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD)"
_commit=$(git rev-parse HEAD)