aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-16 20:44:58 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-16 20:44:58 +0200
commitf9a90e4f8b40e7165f6a3bd42a94fbbe74105c51 (patch)
tree1f46070230ca274d73fc689925488d7957ee2bd2 /linux/makepkg/PKGBUILD
parenturlfilter: Add FilterTree class (diff)
downloadsmolbote-f9a90e4f8b40e7165f6a3bd42a94fbbe74105c51.tar.xz
buildconfig: don't overwrite install prefix by default
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 240f711..c327b47 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -55,14 +55,14 @@ build() {
# generate makefile
# see doc/Building.asciidoc for list of options
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/local \
+ -DCMAKE_INSTALL_PREFIX=/usr/local \
-Dpoi_Version="$_tag" \
-Dpoi_Describe="$pkgver" \
-Dpoi_Build="$_branch:$_commit" \
$srcdir/smolbote
# if you want to manually customize the build, you can use ccmake here
- ccmake .
+ #ccmake .
# Build
make
@@ -70,7 +70,7 @@ build() {
package() {
# Install
- make install
+ DESTDIR="$pkgdir" make install
msg2 "Installing icon and .desktop"
install -Dm644 $srcdir/smolbote/data/poi.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/poi.svg