aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-01-04 14:34:43 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2019-01-04 14:34:43 +0100
commit0c82209bca885b0f9cd80ab4717e63b7dfa75cab (patch)
tree709647dcccb25459baa507aed7e0f491903d315c /meson.build
parentAdd script to generate QtCreator project files (diff)
downloadsmolbote-0c82209bca885b0f9cd80ab4717e63b7dfa75cab.tar.xz
Add assorted unfished doc files to repo
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e5b542c..d903910 100644
--- a/meson.build
+++ b/meson.build
@@ -3,6 +3,12 @@ project('smolbote', 'cpp',
default_options: ['cpp_std=c++17', 'strip=true', 'warning_level=3'],
license: 'GPL3')
+# autogenerate qtcreator project files
+# add_postconf_script(script_name, arg1, arg2, ...)
+# will run the executable given as an argument after all project files have been generated.
+# This script will have the environment variables MESON_SOURCE_ROOT and MESON_BUILD_ROOT set.
+#meson.add_postconf_script('tools/gen-qtcreator-config.py', '--prefix=../smolbote', '.')
+
# Qt 5
qt5 = import('qt5')
dep_qt5 = dependency('qt5', modules: ['Core', 'Network', 'Widgets', 'WebEngineWidgets', 'Test'])