aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 15:17:39 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 15:17:39 +0200
commit12d9dcaf8af2bd668c1f03275d82314347c0c153 (patch)
tree361714e651545099c6f34d2927b47a3f86e7aa9d /meson.build
parentRemove lib/ as includepath (diff)
downloadsmolbote-12d9dcaf8af2bd668c1f03275d82314347c0c153.tar.xz
Fix breakpad integration
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9348bdf..9d4c661 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,9 @@ dep_boost = dependency('boost', modules: ['program_options'])
# Breakpad
dep_breakpad = dependency('breakpad-client', required : get_option('Breakpad'))
+if dep_breakpad.found()
+ dep_thread = dependency('threads')
+endif
# Generate config header
include = include_directories('include')