aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-05-28 22:05:45 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-05-29 14:33:05 +0300
commit149043a24273e5f02ed921e33c256567156fa95a (patch)
tree9cf19007a2dd055e75fb8d9d2335737ae90fb333 /meson.build
parentTurn on more warnings by default (diff)
downloadsmolbote-149043a24273e5f02ed921e33c256567156fa95a.tar.xz
Fix segfault in release build
When creating a WebView out of a Session struct, fall back to the default profile if one is not set, or a profile with that ID is not found. - Update PKGBUILD
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index bc72ff3..56e50e7 100644
--- a/meson.build
+++ b/meson.build
@@ -74,12 +74,7 @@ add_project_arguments(cxx.get_supported_arguments([
#'-Weffc++',
]), language: 'cpp')
-if get_option('buildtype') == 'release'
- add_project_arguments(cxx.get_supported_arguments([
- '-flto=4',
- ]), language: 'cpp')
-endif
-
+# Dependencies
mod_qt5 = import('qt5')
dep_qt5 = dependency('qt5',
modules: [ 'Core', 'Network', 'Widgets', 'Svg', 'WebEngine', 'WebEngineWidgets', 'Concurrent' ],