aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-10-24 19:33:36 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-10-28 09:52:04 +0200
commit54afcf199f487579979fc6902ea8692667c58a63 (patch)
tree55fbfbdf6fb6e251e3ca6e11653b7ab41d63e537 /meson.build
parentFix useless-cast warnings in Configuration (diff)
downloadsmolbote-54afcf199f487579979fc6902ea8692667c58a63.tar.xz
Update wraps
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2ae2941..1dd1a1f 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,11 @@ endif
sourceset = import('sourceset')
cxx = meson.get_compiler('cpp')
-summary({'id': cxx.get_id()}, section: 'Compiler')
+summary({
+ 'id': cxx.get_id(),
+ 'version': cxx.version(),
+ 'linker': cxx.get_linker_id(),
+}, section: 'Compiler')
# add some specific flags
add_project_arguments(cxx.get_supported_arguments([