aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-03-22 14:59:04 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-03-22 14:59:04 +0200
commit74870600fa54a48d4c1ce4b19861a9b0ce027fee (patch)
treed79eb50c18f1f62e937a1d1fe2e7180c7c14d06a /meson.build
parentRemove ProfileInterface (diff)
downloadsmolbote-74870600fa54a48d4c1ce4b19861a9b0ce027fee.tar.xz
lib/configuration improvements
Configuration changes: - Configuration::value return type is now [[nodiscard]] - Configuration::value<T> is now a generic template that only works with the exact types of the underlying std::variant - Add Configuration::value<concept_value_t> for standard library types compatible with the types of std::variant - Add Configuration::shortcut<> placeholder, and QAction and QKeySequence specializations as a convenient way to set up shortcuts - Deprecate setShortcut - Add Configuration::read_file convenience member that takes file path as parameter Format changes: - Configuration files can now have sections, specified as [section name]. Section names are prepended to keys. Section names cannot be nested. - Configuration files can now have @@include directives, causing another file to be read as well. The included file is not treated as nested into a section, and will overwrite values previously set. Others: - add some tests for libconfiguration. QAction/QKeySequence require a QApplication be set up, so the test application may require running xorg/wayland. old coverage: lines: 15.6% (960 out of 6172) branches: 9.9% (1187 out of 12012) new coverage: lines: 17.1% (1067 out of 6254) branches: 11.0% (1388 out of 12644)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3424554..08899fc 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('smolbote', ['cpp'],
version: '0.1.0',
- default_options: ['cpp_std=c++17', 'warning_level=3'],
+ default_options: ['cpp_std=c++2a', 'warning_level=3'],
license: 'GPL3',
meson_version: '>=0.52.0'
)
@@ -31,6 +31,7 @@ add_project_arguments(cxx.get_supported_arguments([
'-ffunction-sections', # Place each function into its own section, better ASLR but larger executables
'-fstack-protector-all', # Emit code to check for buffer overflows on all functions
'-fstack-clash-protection', # Emit code to check for stack clash attacks
+ '-fconcepts',
'-mspeculative-load-hardening', # Spectre v1 mitigation
@@ -90,7 +91,6 @@ subdir('tools')
#subdir('plugins/ConfigurationEditor')
#subdir('plugins/ProfileEditor')
-subdir('test/conf')
subdir('test/firefox-bookmarks-json-parser')
ssconfig = poi_sourceset.apply(cdata)