aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-10-03 18:39:10 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-10-03 18:39:10 +0300
commita8420ae8e2792f305c12840485c74899000ce4e4 (patch)
tree9f8899b946804b03de67ea2546105d46939bed5b /meson.build
parentUpdate Readme (diff)
downloadsmolbote-a8420ae8e2792f305c12840485c74899000ce4e4.tar.xz
Fix deprecated warning in meson.build
Fix warnings in libconfiguration
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df718cc..73963a8 100644
--- a/meson.build
+++ b/meson.build
@@ -16,7 +16,7 @@ kconfig = import('unstable-keyval')
cdata = configuration_data(kconfig.load(host_machine.system() + '/.config'))
version_h = vcs_tag(
- command: [find_program('git').path(), 'describe', '--long', '--abbrev=40'],
+ command: [find_program('git').full_path(), 'describe', '--long', '--abbrev=40'],
#fallback: defaults to meson.project_version(),
input: 'src/version.h.in',
output: 'version.h'
@@ -30,6 +30,7 @@ endif
sourceset = import('sourceset')
cxx = meson.get_compiler('cpp')
+summary({'compiler': cxx.get_id()}, section: 'Compiler')
# add some specific flags
add_project_arguments(cxx.get_supported_arguments([