aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-29 18:49:07 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-05-08 13:40:29 +0300
commite87693c54ca97ed3a6ed25f9eaae8ab223fc18b1 (patch)
tree54194ca979ac7e646ff3f10ed6d7f7753273f0be /meson.build
parentExpand pluginloader test coverage (diff)
downloadsmolbote-e87693c54ca97ed3a6ed25f9eaae8ab223fc18b1.tar.xz
libwebengine
Make src/webengine into a static library - Add some tests - Updated manpage - Remove WebProfileManager::id and WebProfileManager::instance - Add consumable semantics checks to WebProfileManager - Add WebProfileManager::walk Add ApplicationMenu class
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 11 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index adee6c2..3cf7105 100644
--- a/meson.build
+++ b/meson.build
@@ -31,14 +31,18 @@ add_project_arguments(cxx.get_supported_arguments([
'-ffunction-sections', # Place each function into its own section, better ASLR but larger executables
'-fstack-protector-all', # Emit code to check for buffer overflows on all functions
'-fstack-clash-protection', # Emit code to check for stack clash attacks
- '-fconcepts',
- '-mspeculative-load-hardening', # Spectre v1 mitigation
+ # gcc specific
+ '-fconcepts', # gcc9 c++20 compat
- '-Wconsumed', # (clang) use-after-move warnings
- '-Wdate-time', # Warn when using __TIME__ and __DATE__ macros
- '-Wimplicit-fallthrough',
- '-Wold-style-cast'
+ # clang specific
+ '-mspeculative-load-hardening', # Spectre v1 mitigation
+ '-Wconsumed', # use-after-move warnings
+ '-Xclang -plugin-arg-clazy -Xclang level0,level1', # clazy default warning level
+
+ '-Wdate-time', # __TIME__ and __DATE__ macros
+ '-Wimplicit-fallthrough', # switch implicit fallthrough
+ '-Wold-style-cast' # c-style casts
]), language: 'cpp')
if get_option('buildtype') == 'release'
@@ -49,7 +53,7 @@ endif
mod_qt5 = import('qt5')
dep_qt5 = dependency('qt5',
- modules: [ 'Core', 'Network', 'Widgets', 'Svg', 'WebEngineWidgets', 'Concurrent', 'Test' ],
+ modules: [ 'Core', 'Network', 'Widgets', 'Svg', 'WebEngine', 'WebEngineWidgets', 'Concurrent' ],
include_type: 'system'
)