aboutsummaryrefslogtreecommitdiff
path: root/plugins/ProfileEditor/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 20:34:50 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-14 20:34:50 +0100
commit037b039bfbfeda2e9b7ebef7e38616575411c876 (patch)
tree6767f8edc0860b60b590dc30a37319a7c1c66a0d /plugins/ProfileEditor/CMakeLists.txt
parentMinor fixes (diff)
downloadsmolbote-037b039bfbfeda2e9b7ebef7e38616575411c876.tar.xz
Initial plugins testing
Diffstat (limited to 'plugins/ProfileEditor/CMakeLists.txt')
-rw-r--r--plugins/ProfileEditor/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/ProfileEditor/CMakeLists.txt b/plugins/ProfileEditor/CMakeLists.txt
new file mode 100644
index 0000000..3eaa0f5
--- /dev/null
+++ b/plugins/ProfileEditor/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.1.0)
+
+find_package(Qt5Core REQUIRED)
+find_package(Qt5Widgets REQUIRED)
+find_package(Qt5WebEngineWidgets REQUIRED)
+
+set(CMAKE_AUTOMOC ON)
+
+add_library(ProfileEditorPlugin SHARED
+ profileeditorplugin.cpp
+ profileeditorplugin.h)
+
+target_include_directories(ProfileEditorPlugin
+ PUBLIC ..)
+
+target_link_libraries(ProfileEditorPlugin
+ PRIVATE Qt5::Widgets
+ PRIVATE Qt5::WebEngineWidgets)