aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-07 13:03:47 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-07 13:03:47 +0200
commit7707fb4ed8ad8c951d9f41ce39823093d30a9f67 (patch)
treea70e08ba2d03afb68109ea89f370f8873e3645f5 /src/CMakeLists.txt
parentDon't copy profiles into profile manager plugin (diff)
downloadsmolbote-7707fb4ed8ad8c951d9f41ce39823093d30a9f67.tar.xz
Split webengine/webprofile into lib/web
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d0ac915..0c6876d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -33,8 +33,6 @@ add_executable(poi
# webengine
webengine/urlinterceptor.cpp
webengine/urlinterceptor.h
- webengine/webprofile.cpp
- webengine/webprofile.h
webengine/webpage.cpp
webengine/webpage.h
webengine/webview.cpp
@@ -51,7 +49,8 @@ add_executable(poi
target_include_directories(poi
PRIVATE ${Boost_INCLUDE_DIRS}
PRIVATE ../lib ../plugins
- PRIVATE ../lib/configuration)
+ PRIVATE ../lib/configuration
+ PRIVATE ../lib/web)
target_link_libraries(poi
Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineWidgets
@@ -59,7 +58,7 @@ target_link_libraries(poi
about
addressbar
configuration
- bookmarks downloads)
+ bookmarks downloads web)
target_compile_definitions(poi
PRIVATE QTBUG_65223_WORKAROUND