aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 15:17:39 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 15:17:39 +0200
commit12d9dcaf8af2bd668c1f03275d82314347c0c153 (patch)
tree361714e651545099c6f34d2927b47a3f86e7aa9d /src/meson.build
parentRemove lib/ as includepath (diff)
downloadsmolbote-12d9dcaf8af2bd668c1f03275d82314347c0c153.tar.xz
Fix breakpad integration
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 9ce42d4..0af2be0 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -9,9 +9,14 @@ poi_moc = qt5.preprocess(
dependencies: dep_qt5
)
+features = []
+if dep_breakpad.found()
+ features += '-DBreakpadEnabled'
+endif
+
poi = executable('poi', install: true,
- cpp_args: '-DQAPPLICATION_CLASS=QApplication',
- dependencies: [dep_qt5, dep_boost, dep_breakpad, dep_SingleApplication,
+ cpp_args: ['-DQAPPLICATION_CLASS=QApplication', features],
+ dependencies: [dep_qt5, dep_boost, dep_breakpad, dep_thread, dep_SingleApplication,
dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_web],
include_directories: [include, genheader_inc],
sources: ['main.cpp', poi_moc,