aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 03:58:33 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-23 03:58:33 +0200
commit6673ba53c17bb1ab99a1e7629156d99452213747 (patch)
tree70cf515693ed51c5537dc5fb178e5d938862bd35 /src/meson.build
parentAdblockRule constructor (diff)
downloadsmolbote-6673ba53c17bb1ab99a1e7629156d99452213747.tar.xz
Initial meson build files
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..83ef998
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,34 @@
+# poi
+poi_moc = qt5.preprocess(
+ moc_headers: [],
+ ui_files: ['mainwindow/mainwindow.ui', 'mainwindow/widgets/searchform.ui'],
+ qresources: '../data/resources.qrc',
+ dependencies: dep_qt5
+)
+
+poi = executable('poi', install: true,
+ dependencies: [dep_qt5, dep_boost, dep_breakpad, dep_SingleApplication,
+ dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_web],
+ cpp_args : '-DQAPPLICATION_CLASS=QApplication',
+ include_directories: [include, genheader_inc, lib_inc, thirdparty_inc],
+ sources: ['main.cpp', poi_moc,
+ 'browser.cpp', 'browser.h',
+ 'session.cpp', 'session.h',
+ 'util.cpp', 'util.h',
+
+ 'mainwindow/mainwindow.cpp', 'mainwindow/mainwindow.h',
+ 'mainwindow/widgets/dockwidget.cpp', 'mainwindow/widgets/dockwidget.h',
+ 'mainwindow/widgets/navigationbar.cpp', 'mainwindow/widgets/navigationbar.h',
+ 'mainwindow/widgets/searchform.cpp', 'mainwindow/widgets/searchform.h',
+
+ 'subwindow/subwindow.cpp', 'subwindow/subwindow.h',
+ 'subwindow/tabwidget.cpp', 'subwindow/tabwidget.h',
+
+ 'webengine/filter.cpp', 'webengine/filter.h',
+ 'webengine/urlinterceptor.cpp', 'webengine/urlinterceptor.h',
+ 'webengine/webpage.cpp', 'webengine/webpage.h',
+ 'webengine/webview.cpp', 'webengine/webview.h',
+
+ 'wallet/wallet.cpp', 'wallet/wallet.h']
+)
+