aboutsummaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-02-23 22:36:17 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2019-02-23 22:36:17 +0200
commit914e2be5f52f19a995649bed047e9d2d814a6a42 (patch)
tree53b82dc4d04acdc4522b695e8aec972913bd832c /src/meson.build
parentSubWindow: closing tab restores previous index (diff)
downloadsmolbote-914e2be5f52f19a995649bed047e9d2d814a6a42.tar.xz
Add WIP Python REPL interface
- Requires Python >= 3.0.0 and linenoise or linenoise-ng - WIP: not built into the browser itself
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 6d5a42e..ef0f989 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,5 +1,5 @@
# poi
-poi_moc = qt5.preprocess(
+poi_moc = mod_qt5.preprocess(
moc_headers: ['browser.h',
'mainwindow/mainwindow.h', 'mainwindow/menubar.h', 'mainwindow/widgets/dockwidget.h', 'mainwindow/widgets/menusearch.h', 'mainwindow/widgets/navigationbar.h', 'mainwindow/widgets/searchform.h',
'session/savesessiondialog.h', 'session/sessiondialog.h', 'session/sessionform.h',
@@ -13,7 +13,7 @@ poi_moc = qt5.preprocess(
poi = executable(get_option('poiName'), install: true,
cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
- dependencies: [dep_qt5, dep_boost, dep_SingleApplication, dep_genheaders, dep_breakpad, dep_plasma, dep_spdlog,
+ dependencies: [dep_qt5, dep_boost, dep_spdlog, dep_SingleApplication, dep_genheaders, optional_deps,
dep_about, dep_addressbar, dep_bookmarks, dep_configuration, dep_downloads, dep_urlfilter, dep_webprofile],
include_directories: [include],
sources: ['main.cpp', 'builtins.cpp', 'crashhandler.cpp', poi_moc,