aboutsummaryrefslogtreecommitdiff
path: root/test/matcherbenchmark/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-02-10 20:58:39 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-05-30 11:01:35 +0300
commitd1287f43964633035938f4f4d4133bb6d9da7b3e (patch)
treed09efa4074815c20be9bd6348203fe4336dfe716 /test/matcherbenchmark/meson.build
parentFix segfault in release build (diff)
downloadsmolbote-d1287f43964633035938f4f4d4133bb6d9da7b3e.tar.xz
staging: smolblok
smolblok is a replacement for the current lib/urlfilter AdBlockPlus and hostlist format filter parser. It is a library that uses plugins to provide support for different filter formats. staging/adblock: AdBlockPlus parser plugin plugins/smolblok_hostlist: hostlist format parser plugin Headers will be installed to include/smolbote/ Remove lib/urlfilter
Diffstat (limited to 'test/matcherbenchmark/meson.build')
-rw-r--r--test/matcherbenchmark/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/matcherbenchmark/meson.build b/test/matcherbenchmark/meson.build
new file mode 100644
index 0000000..64efd0b
--- /dev/null
+++ b/test/matcherbenchmark/meson.build
@@ -0,0 +1,7 @@
+subdir_done()
+
+executable('matcherbenchmarks',
+ sources: [ 'matcherbenchmark.cpp',
+ mod_qt5.preprocess(moc_headers: 'matcherbenchmark.h')],
+ dependencies: [ dep_qt5 ]
+)