aboutsummaryrefslogtreecommitdiff
path: root/3rd-party/breakpad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rd-party/breakpad/CMakeLists.txt')
-rw-r--r--3rd-party/breakpad/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/3rd-party/breakpad/CMakeLists.txt b/3rd-party/breakpad/CMakeLists.txt
new file mode 100644
index 0000000..dd0ef8e
--- /dev/null
+++ b/3rd-party/breakpad/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+
+ if (NOT EXISTS "${CMAKE_CURRENT_LIST_DIR}/install")
+ message(FATAL_ERROR "Could not find breakpad build, see 3rd-party/breakpad/build.sh")
+ endif ()
+
+ find_package(PkgConfig REQUIRED)
+ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${CMAKE_CURRENT_LIST_DIR}/install/lib/pkgconfig" )
+ pkg_check_modules(BREAKPAD REQUIRED IMPORTED_TARGET breakpad-client)
+
+endif() # linux system \ No newline at end of file