aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b9e25d..f582600 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,7 @@ option(MercurialRepo "Get version information from .hg" ON)
option(CompilerWarnings "Compiler warnings" ON)
option(QtDeprecatedWarnings "Qt deprecated warnings" ON)
option(UseLibCpp "Use libc++ over stdlibc++ (requires clang)" OFF)
+option(Tests "Enable/disable some basic autotests" ON)
# Libraries
find_package(Qt5 COMPONENTS Core Widgets Concurrent REQUIRED)
@@ -61,4 +62,10 @@ add_subdirectory(src)
# configuration program
add_subdirectory(config)
+if (Tests)
+ enable_testing()
+ find_package(Qt5 COMPONENTS Test REQUIRED)
+ add_subdirectory(test)
+endif()
+
feature_summary(WHAT ALL)