aboutsummaryrefslogtreecommitdiff
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
index 129b2f2..cde4648 100644
--- a/config/CMakeLists.txt
+++ b/config/CMakeLists.txt
@@ -1,8 +1,11 @@
-cmake_minimum_required(VERSION 3.1.0)
-
# Find includes in corresponding build directories
set(CMAKE_INCLUDE_CURRENT_DIR ON)
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_AUTORCC ON)
+
add_executable(poi-config
main.cpp
settingsdialog.cpp
@@ -11,5 +14,8 @@ add_executable(poi-config
../src/configuration.cpp
)
-target_link_libraries(poi-config Qt5::Core Qt5::Widgets)
-target_link_libraries(poi-config ${Boost_LIBRARIES})
+target_link_libraries(poi-config
+ Qt5::Core Qt5::Widgets
+ ${Boost_LIBRARIES})
+
+install(TARGETS poi-config RUNTIME DESTINATION bin CONFIGURATIONS Release)