aboutsummaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 6e51e39..d45aea1 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -11,4 +11,18 @@ if get_option('manpage').enabled()
install: true, install_dir: join_paths(get_option('mandir'), 'man7')
)
+ custom_target('manpage.5',
+ # list of files this target depends on
+ depend_files: ['smolbote.5.asciidoc'],
+
+ input: 'smolbote.5.asciidoc',
+ output: 'smolbote.5',
+
+ command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
+
+ build_by_default: true,
+ install: true,
+ install_dir: get_option('mandir') / 'man5'
+ )
+
endif