aboutsummaryrefslogtreecommitdiff
path: root/lib/about/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/about/CMakeLists.txt')
-rw-r--r--lib/about/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/about/CMakeLists.txt b/lib/about/CMakeLists.txt
new file mode 100644
index 0000000..56cd646
--- /dev/null
+++ b/lib/about/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_AUTORCC ON)
+
+add_library(about
+ aboutdialog.cpp
+ aboutdialog.h
+ aboutdialog.ui
+)
+
+target_link_libraries(about Qt5::Widgets)