aboutsummaryrefslogtreecommitdiff
path: root/lib/downloads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/downloads/CMakeLists.txt')
-rw-r--r--lib/downloads/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/downloads/CMakeLists.txt b/lib/downloads/CMakeLists.txt
index ca67f0a..ad1a3fe 100644
--- a/lib/downloads/CMakeLists.txt
+++ b/lib/downloads/CMakeLists.txt
@@ -1,4 +1,10 @@
-cmake_minimum_required(VERSION 3.1.0)
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_AUTORCC ON)
add_library(downloads
downloadsform.ui