aboutsummaryrefslogtreecommitdiff
path: root/lib/downloads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/downloads/CMakeLists.txt')
-rw-r--r--lib/downloads/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/downloads/CMakeLists.txt b/lib/downloads/CMakeLists.txt
new file mode 100644
index 0000000..ca67f0a
--- /dev/null
+++ b/lib/downloads/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.1.0)
+
+add_library(downloads
+ downloadsform.ui
+ downloadswidget.cpp
+ downloadswidget.h
+ widgets/downloaditemform.ui
+ widgets/downloaditemwidget.cpp
+ widgets/downloaditemwidget.h
+ widgets/elidedlabel.cpp
+ widgets/elidedlabel.h)
+
+target_link_libraries(downloads Qt5::Widgets Qt5::WebEngineWidgets) \ No newline at end of file