aboutsummaryrefslogtreecommitdiff
path: root/lib/downloads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/downloads/CMakeLists.txt')
-rw-r--r--lib/downloads/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/downloads/CMakeLists.txt b/lib/downloads/CMakeLists.txt
new file mode 100644
index 0000000..b310e3a
--- /dev/null
+++ b/lib/downloads/CMakeLists.txt
@@ -0,0 +1,8 @@
+add_library(downloads STATIC
+ downloadsform.ui
+ downloadswidget.cpp downloadswidget.h
+ widgets/downloaditemform.ui widgets/downloaditemwidget.cpp widgets/downloaditemwidget.h
+ widgets/elidedlabel.cpp widgets/elidedlabel.h
+)
+target_link_libraries(downloads PUBLIC Qt6::Widgets Qt6::WebEngineWidgets)
+target_include_directories(downloads PUBLIC ${CMAKE_CURRENT_LIST_DIR})