aboutsummaryrefslogtreecommitdiff
path: root/lib/urlfilter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/urlfilter/CMakeLists.txt')
-rw-r--r--lib/urlfilter/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/urlfilter/CMakeLists.txt b/lib/urlfilter/CMakeLists.txt
new file mode 100644
index 0000000..842f18f
--- /dev/null
+++ b/lib/urlfilter/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+
+add_library(urlfilter
+ filterrule.cpp
+ filterrule.h
+
+ formats/adblockrule.cpp
+ formats/adblockrule.h
+)
+
+target_link_libraries(urlfilter Qt5::WebEngineWidgets)