aboutsummaryrefslogtreecommitdiff
path: root/lib/web/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/web/CMakeLists.txt')
-rw-r--r--lib/web/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/web/CMakeLists.txt b/lib/web/CMakeLists.txt
new file mode 100644
index 0000000..c5d5eba
--- /dev/null
+++ b/lib/web/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+
+add_library(web
+ webprofile.cpp
+ webprofile.h
+)
+
+#target_include_directories(web
+# PRIVATE ${Boost_INCLUDE_DIRS}
+# PRIVATE ..
+#)
+
+target_link_libraries(web Qt5::WebEngineWidgets)