aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD.generic
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD.generic')
-rw-r--r--linux/makepkg/PKGBUILD.generic47
1 files changed, 47 insertions, 0 deletions
diff --git a/linux/makepkg/PKGBUILD.generic b/linux/makepkg/PKGBUILD.generic
new file mode 100644
index 0000000..9a17f9b
--- /dev/null
+++ b/linux/makepkg/PKGBUILD.generic
@@ -0,0 +1,47 @@
+# Maintainer: Aqua-sama <aqua@iserlohn-fortress.net>
+
+pkgname=smolbote-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc='Yet another no-frills browser'
+url="https://neueland.iserlohn-fortress.net/smolbote"
+
+arch=('x86_64')
+license=('GPL3')
+
+depends=('qt5-base' 'qt5-webengine')
+makedepends=('git' 'cmake' 'libconfig' 'pkg-config')
+
+source=("smolbote-git::git+git://neueland.iserlohn-fortress.net/smolbote.git")
+sha512sums=('SKIP')
+
+# any patches go here
+#prepare() {
+#}
+
+pkgver() {
+ cd smolbote-git
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ rm -rf "$pkgname-$pkgver"
+ mkdir "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
+
+ # Generate a makefile
+ # Adjust the install prefix as necessary, default is /usr/local/bin
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/local "$srcdir/smolbote-git"
+
+ # Use this if you want to link with libc++ instead
+ # This requires clang, since gcc doesn't understand the concept of not using libstdc++
+ #cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_CXX_COMPILER=/usr/bin/clang++ -DUseLibCpp=On "$srcdir/smolbote-git"
+
+ # build, with 4 threads
+ make -j 4
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}