aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index fc3d16d..9a45114 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -36,7 +36,11 @@ prepare() {
pkgver() {
cd smolbote
+ # Without version tag
echo r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD) | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+ # With version tag
+ #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -52,6 +56,9 @@ build() {
# --auto-features=disabled - features should be explicitly enabled
meson --buildtype=plain --prefix=/usr/local --auto-features=disabled $srcdir/build
+ # Run menuconfig
+ #KCONFIG_CONFIG=linux/.config menuconfig
+
cd $srcdir/build
# Toggle features