aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9310eb0..121b472 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('smolbote', 'cpp',
- version: 'master',
+ version: '0.1.0',
default_options: ['cpp_std=c++17', 'strip=true', 'warning_level=3'],
license: 'GPL3',
meson_version: '>=0.49.0'
@@ -26,6 +26,8 @@ dep_boost = dependency('boost', modules: ['program_options'])
dep_spdlog = dependency('spdlog', fallback: ['spdlog', 'spdlog_dep'], version: '>=1.3.1')
+dep_openssl = dependency('openssl')
+
optional_deps = []
if get_option('Breakpad').enabled()