aboutsummaryrefslogtreecommitdiff
path: root/plugins/ConfigurationEditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ConfigurationEditor/CMakeLists.txt')
-rw-r--r--plugins/ConfigurationEditor/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/plugins/ConfigurationEditor/CMakeLists.txt b/plugins/ConfigurationEditor/CMakeLists.txt
deleted file mode 100644
index 7eb6de4..0000000
--- a/plugins/ConfigurationEditor/CMakeLists.txt
+++ /dev/null
@@ -1,30 +0,0 @@
-find_package(Qt5Core REQUIRED)
-find_package(Qt5Widgets REQUIRED)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTOUIC ON)
-
-add_library(ConfigurationEditorPlugin SHARED
- ${CMAKE_SOURCE_DIR}/include/plugininterface.h
- ${CMAKE_SOURCE_DIR}/include/browserinterface.h
-
- configurationeditorplugin.cpp
- configurationeditorplugin.h
- forms/configurationdialog.cpp
- forms/configurationdialog.h
- forms/configurationdialog.ui
-)
-
-target_include_directories(ConfigurationEditorPlugin
- PRIVATE ${CMAKE_SOURCE_DIR}/include
-)
-
-target_link_libraries(ConfigurationEditorPlugin
- PRIVATE Qt5::Widgets
-)
-
-if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
- install(TARGETS ConfigurationEditorPlugin RUNTIME DESTINATION ${CONFIG_INSTALL_PLUGINDIR} CONFIGURATIONS Release)
-else()
- install(TARGETS ConfigurationEditorPlugin LIBRARY DESTINATION ${CONFIG_INSTALL_PLUGINDIR} CONFIGURATIONS Release)
-endif()