aboutsummaryrefslogtreecommitdiff
path: root/plugins/ProfileEditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ProfileEditor/CMakeLists.txt')
-rw-r--r--plugins/ProfileEditor/CMakeLists.txt38
1 files changed, 21 insertions, 17 deletions
diff --git a/plugins/ProfileEditor/CMakeLists.txt b/plugins/ProfileEditor/CMakeLists.txt
index 7c9a774..5bcfcce 100644
--- a/plugins/ProfileEditor/CMakeLists.txt
+++ b/plugins/ProfileEditor/CMakeLists.txt
@@ -9,31 +9,35 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTOUIC ON)
add_library(ProfileEditorPlugin SHARED
- profileeditorplugin.cpp
- profileeditorplugin.h
- forms/profileview.cpp
- forms/profileview.h
- forms/profileview.ui
- forms/profilemanagerdialog.cpp
- forms/profilemanagerdialog.h
- forms/profilemanagerdialog.ui
- forms/newprofiledialog.cpp
- forms/newprofiledialog.h
- forms/newprofiledialog.ui
- forms/newhttpheaderdialog.cpp
- forms/newhttpheaderdialog.h
- forms/newhttpheaderdialog.ui
+ ${CMAKE_SOURCE_DIR}/include/profileinterface.h
+ ${CMAKE_SOURCE_DIR}/include/browserinterface.h
+ ${CMAKE_SOURCE_DIR}/include/plugininterface.h
+
+ profileeditorplugin.cpp
+ profileeditorplugin.h
+
+ forms/profilemanagerdialog.cpp
+ forms/profilemanagerdialog.h
+ forms/profilemanagerdialog.ui
+ forms/profileview.cpp
+ forms/profileview.h
+ forms/profileview.ui
+
+ forms/newprofiledialog.cpp
+ forms/newprofiledialog.h
+ forms/newprofiledialog.ui
+ forms/newhttpheaderdialog.cpp
+ forms/newhttpheaderdialog.h
+ forms/newhttpheaderdialog.ui
)
target_include_directories(ProfileEditorPlugin
- PRIVATE ${CMAKE_SOURCE_DIR}/plugins
- PRIVATE ${CMAKE_SOURCE_DIR}/lib/web
+ PRIVATE ${CMAKE_SOURCE_DIR}/include
)
target_link_libraries(ProfileEditorPlugin
PRIVATE Qt5::Widgets
PRIVATE Qt5::WebEngineWidgets
- PRIVATE web
)
if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")