aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index df2aeeb..e256ee8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,6 +47,10 @@ set(srclist
plugin.h
)
+if(Breakpad)
+ link_directories("${BREAKPAD_LIBRARY_DIRS}")
+endif()
+
if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
add_executable(${poi_exe} WIN32 ${srclist} ${PROJECT_SOURCE_DIR}/data/windows.rc)
else()
@@ -70,6 +74,16 @@ target_link_libraries(${poi_exe}
bookmarks downloads web
)
+if(Breakpad)
+ find_package(Threads REQUIRED)
+
+ target_link_libraries(${poi_exe} Threads::Threads ${BREAKPAD_LIBRARIES})
+ target_include_directories(${poi_exe} PRIVATE ${BREAKPAD_INCLUDE_DIRS})
+ target_compile_options(${poi_exe} PRIVATE ${BREAKPAD_CFLAGS_OTHER})
+
+ target_compile_definitions(${poi_exe} PRIVATE BreakpadEnabled)
+endif()
+
if(Plasma)
target_link_libraries(${poi_exe} KF5::WindowSystem)
target_compile_definitions(${poi_exe}